Anyone else having this problem??

Post Reply
buyitall
Posts: 237
Joined: 2 years ago

Anyone else having this problem??

Post by buyitall » 2 weeks ago

I am having problems with the auction site. When I click on online auctions it takes forever and does not show the list of items. ALSO, I am bidding on a Navajo pearl bracelet and it will just not show up in my watch list! I had this problem 2 weeks ago with an item I was bidding on that wouldn’t show up in my watch list. I contacted customer service…needless to say it was not resolved! Just want to know if others are having problems or if it’s my Apple iPad??? Had iPad checked when I was having another auction site problem…and it was NOT my iPad! However, ShopLC insisted there was nothing wrong on their end. Odd…the ONLY site I visit on the internet that I constantly have problems with…is ShopLC’s auction site????!!!
1 x

MaeWest1953
Posts: 478
Joined: 1 year ago

Re: Anyone else having this problem??

Post by MaeWest1953 » 2 weeks ago

Hello Buyitall.....

I have an Apple Ipad but it's so old that I believe that could be one of the reasons I can't see certain things on the website
No way can I see the recently air items except for the last 25, nor can I come to the community forum, I am on my desktop right now in order to see it and participate
Sure hope you can get some answers....I know it can be so frustrating
0 x

Ruby
Posts: 43
Joined: 2 years ago

Re: Anyone else having this problem??

Post by Ruby » 1 week ago

I have been having the same trouble for several weeks. I bid on items but my bids don't show up. I also get the notice to "be the first bidder" and when I click to bid I get the message another bidder has an astronomical bid that isn't shown until you click to bid. I have had three instances where I watched my bid be the winning bid for an item and then the item didn't show up for purchase in my auction cart. The most suspect thing I have seen, however, was when I was the winner on a nice piece for a very low price and when I went to purchase it, the "time remaining" was only 1 second even though it had only been a few hours since I won. Of course, when I clicked on it to purchase, the second expired and the item was no longer available. I have very little faith in the LC auction now and go into it expecting to be cheated or outbid by the computer. If I do happen to win something, I take a screen shot and immediately purchase it. It is a real shame because the auction used to be a lot of fun and I could get nice items for relatively decent prices. Not so much the case anymore. I just lowered my expectations from this company and now I am only pleasantly surprised it I do get an item.
4 x

GEMLUVIN
Posts: 4
Joined: 2 years ago

Re: Anyone else having this problem??

Post by GEMLUVIN » 1 week ago

Yes, at first I thought it was my wifi, but all other devices worked fine in same time frame. I also found that won items are being pulled from cart and listed as won -expired with more than 10 hours left to pay, including the autopay feature.
2 x

BostonIrish
Posts: 82
Joined: 4 months ago

Re: Anyone else having this problem??

Post by BostonIrish » 1 week ago

I called them we shall see if they put our items back just what kind of GAME is this? 😱
1 x

Druid
Posts: 180
Joined: 2 years ago

Re: Anyone else having this problem??

Post by Druid » 1 week ago

Auction items disappearing after just a few hours from winning became a common fact. Shoplc needs to have the decency to announce if there is a change in their policy. It seems that they do not care if they push customers away.
1 x

FarmMom
Posts: 11
Joined: 4 months ago

Re: Anyone else having this problem??

Post by FarmMom » 3 days ago

I've had all the issues mentioned.

I HAVE found that as far as trying to bid on stuff, I think it's a cookie issue (and a coding issue). I don't foresee it getting fixed. The website is no doubt created in India, and my experience with Indian coders is they are trying to get a product done quickly and don't check their work. So you end up with "holes" while traveling through the website. I was hired on at a company for marketing, and ended up getting paid to "find" all the coding errors on their new website developed in India, lol. It was so bad, they ultimately had to give up on the website and shut that part of the company down.

Granted, this is a VERY complicated website to try to build, but I'm sure quality control is STILL an issue and likely that's what's happening.

Issues I have had: I click on jeweler and it only displayed 50 items (should be 3,000).

Trouble displaying ANY of the items searched for.

Bid item not showing up on my auction list *** best way is to keep this item open in a new tab and check on it and bid this way, then it can't ghost you.

Won items showing 8 hrs left to buy then suddenly disappearign an hour later.

Not getting free shipping for orders over $50.

Ghost bidders.

And so much more!


but, as far as search results when trying to look through current auction listings, try loggin out, closing that brower and re-opening it and logging back in. I have found somethings that works. But usually it's just a crap shoot :P
1 x

Post Reply